【Raspberry Pi】Raspbian Jessie with PixelのChromiumにFlashを入れる

RASPBIAN JESSIE WITH PIXELのChromiumにFlashを入れる

【2017.1.30追記】

現在公開されている「Raspbian Jessie with Pixel」では標準でScratch 2.0が動作します。この記事の作業を行う必要はありません

【Raspberry Pi & Scratch】最新のRaspbian Jessie with Pixel(version 4.4.34)ではScratch 2.0が標準で動くよ
最新のNOOBS(2.1.0)をダウンロードして、Raspbian Jessie with Pixelをインストールし直したところ、...

「Raspbian Jessie with Pixel」からはChromiumが標準ブラウザになりました。が、Flashプラグインが入っていない(古いバージョンが入っています)のでScratchを動かすことができません

【2016.11.13追記】
デフォルトでは古いバージョン(11.2.999.999)のFlashプラグインがインストールされています
動かすFlashによっては、このバージョンでも問題ないかもしれません

Scratchは動かなかったので、新しいFlashプラグインをインストールする必要があります
この記事でインストールできるFlashプラグインのバージョンは21.0.0.182-r1です
【2016.11.13追記おわり】

FlashのインストールはRaspberry Piのフォーラムにあるこの手順通りやればOKです
Raspberry Pi • View topic – Howto: Pepper Flash Player for Chromium-Browser

日本語で手順を説明します

こちらから「flash21.tar.xz」をダウンロード
http://www.mediafire.com/download/0i6v4jdq2y2qved/flash21.tar.xz

ダウンロードしたファイルを解凍して、解凍後のファイルを所定の場所にコピーします

tar -xJf flash21.tar.xz
cd pepper
sudo cp *.so /usr/lib/chromium-browser
sudo cp *.json /usr/lib/chromium-browser

01-pepperというファイルを作成します

sudo nano /etc/chromium-browser/customizations/01-pepper

01-pepperにこの一文を追加します

CHROMIUM_FLAGS="${CHROMIUM_FLAGS} --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-version=21.0.0.182-r1 -password-store=detect -user-data-dir"

追加したら
CTRL+Oでリターン
CTRL+Xでファイルを閉じます

chromiumを起動して、URLの入力欄に
chrome://plugins
といれて、Adobe Flash Playerがあればインストール完了です

RASPBIAN JESSIE WITH PIXELのChromiumにFlashを入れる

「常に実行を許可する」をチェックしないと、Flashが再生される前に確認画面が入ります。これが面倒なら「常に実行を許可する」をチェックしておけばOKです

RASPBIAN JESSIE WITH PIXELのChromiumにFlashを入れる

関連コンテンツ
ブログランキング
  • にほんブログ村 教育ブログ プログラミング教育へ
  • にほんブログ村 子育てブログ 子供の習い事(教室・業者)へ

  • スポンサーリンク
    Google336 記事下
    Google336 記事下

    シェアする

    • このエントリーをはてなブックマークに追加

    フォローする

    スポンサーリンク
    Google336 記事下

    コメント

    1. みやお より:

      古いバージョンのFlashが入っています。
      当方はネットのストリーミングを聞こうとして、Flashがoffになっているのに気付かず、最新化しようとしてハマりました。
      旧バージョンでonにすればストリーミングは問題ありませんでした。

      • inafuku より:

        デフォルトで古いバージョンがインストールされているのは気づきませんでした
        動かすFlashによっては、古いバージョンでも問題なさそうですね
        記事にも追記しました
        どうもありがとうございます!

    トップへ戻る