【マイクラMod】ガリバーModとLittle Blocksを入れる

ガリバーmod

「Gulliver the Resizing Mod」と「Little Blocks」を組み合わせるとミニチュアのような家を作って、自分もその建物の中に入る事ができるようになります

このModのインストールに非常に苦労したので、動作に至るまでの手順を残しておきます。Mac版でインストールしましたが、modのインストール部分は他のプラットフォームでも変わらないと思います

スポンサーリンク
Google336 記事下

今回インストールするMod

インストールするModはこの2つ

  • Gulliver the Resizing Mod
    主人公のキャラを小さくしたり大きくしたりできるmod。ガリバーMod
  • Little Blocks
    普通のブロックより小さなブロックが利用できるようになるMod

インストールするMinecraftのバージョン

Gulliver the Resizing Modの最新版のサポートがMinecraftのバージョン1.6.4なので、他のmodやforgeも1.6.4に合わせます

mod関連のダウンロードは全てガリバーmodを紹介しているページからダウンロードできます

Minecraft Forge build 9.11.1.965をインストール

まずmodを利用するのに必要なForgeをインストールします。インストール済みならもちろん必要ありません。

ガリバーmodはForge build 9.11.1.965が必要らしいので、このバージョンのForgeをインストールします
ガリバーmodのサイトのリンクからダウンロードできます
[MC/Forge][1.6.4] Gulliver the Resizing Mod (v0.14.3 *Oct 21*): changing your perspective of Minecraft [OVER 900,000 downloads] – Minecraft Mods – Mapping and Modding – Minecraft Forum – Minecraft Forum

このリンクです
ガリバーmod

forgeのインストールはこちらが詳しいです。forgeをインストールした事がない人は目を通しておいたほうがいいです。
https://napoan.com/new-way-to-install-mod/

Gulliver the Resizing Modをインストール

forgeがインストールできたら、次にガリバーmodをインストールします
ガリバーmodも同じサイトからダウンロードします
[MC/Forge][1.6.4] Gulliver the Resizing Mod (v0.14.3 *Oct 21*): changing your perspective of Minecraft [OVER 900,000 downloads] – Minecraft Mods – Mapping and Modding – Minecraft Forum – Minecraft Forum

このリンク
ガリバーmod

ガリバーmodはmodsディレクトリに入れても動きません。ダウンロードしたファイルを実行してインストールしてください。

Minecraftを起動

ガリバーmodをインストールすると新しくプロファイル(1.6.4 Forge965 GulliverForged)が作成されているので、それを選んで起動します

ここで起動すれば問題無しです
・・・が僕の環境では動きませんでした。その場合は次のステップに進んでください。

起動しない場合

マイクラのゲームディレクトリ(GameDirectory)にForgeModLoader-client-0.logというファイルができていると思うので、そちらを開きます

もし

[重大] [ForgeModLoader] Unable to launch
java.util.ConcurrentModificationException
	at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901)
	at java.util.ArrayList$Itr.remove(ArrayList.java:865)
	at net.minecraft.launchwrapper.Launch.launch(Launch.java:114)
	at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

というエラーが出ているなら、Java7ではなくJava8がインストールされているのが原因だと思われます。

なので、Java8アンイストールしてJava7をインストールすれば解決します
(本当はセキュリティ的にJava8を使ったほうがいいのですが、致し方ない)

Java8をアンイストールする

Java8が入った状態だとJava7をインストールできないので、Java8をアンイストールします

やり方はこちら
古いバージョンのJavaをシステムからアンインストールしなければならないのはなぜですか。

macだと、コンソールを起動して以下のコマンドを1行ずつ実行すればJava8が削除されます

sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo rm -fr /Library/PreferencesPanes/JavaControlPanel.prefpane

Java7をインストールする

オラクルのサイトからJava7をダウンロードします。古いバージョンをダウンロードするにはOracleプロファイルというものに登録する必要があります。住所まで入れないとダメなのでちょっと登録に躊躇してしまいますが、しぶしぶ登録します。

Oracle Java Archive | Oracle Technology Network | Oracle

上のサイトの「Java SE 7」を選ぶと・・・
いっぱいダウンロードのリンクがあるページが表示されますが、「Java SE Runtime Environment 7u80」の自分の環境にあったファイルをダウンロードします
macなら「jre-7u80-macosx-x64.dmg」ですね

ダウンロードできたらインストールします
インストールできたらminecraftを起動します。これでも起動できない場合は、次のステップ

プロファイル「1.6.4 Forge965 GulliverForged」を編集

「1.6.4 Forge965 GulliverForged」の「Edit Profile」を選んで

ガリバーmod

Java SettingsのExecutableにチェックを入れて、今回インストールしたJava7へのパスを入れます

ガリバーmod

Javaのパスは、コントロールパネルからJavaコントロールパネルを開いて、Java Runtime Environment設定を見ればわかります。

ガリバーmod

ガリバーmod

これで起動するはずです。
これでダメだとちょっと僕にはお手上げです・・・ごめんなさい

Little Blocksをインストール

ガリバーmodが入ったので、Little Blocksを入れます
この2つをダウンロードします。(Littele BlocksにはSlimevoidLibが必要なのです)

  • Little Blocks 2.2.3.1
  • SlimevoidLib 2.1.0.0

ガリバーmodのサイトのリンクからダウンロードできます

ガリバーmod

ダウンロードしたファイルを解凍せずそのままmodsフォルダに入れます
LittleBlocks-1.6.4-2.2.3.1.zip
SlimevoidLib-1.6.4-2.1.0.0-2.zip

これで、ガリバーmodとLittle Blocksが導入されたminecraftが起動します

おしまいです。

関連コンテンツ
A8広告
ブログランキング
  • にほんブログ村 子育てブログ 子供の習い事(教室・業者)へ

  • スポンサーリンク
    Google336 記事下
    Google336 記事下

    シェアする

    • このエントリーをはてなブックマークに追加

    フォローする

    トップへ戻る